OP-COM 1.59 compatible

$15.80

OP-COM 1.59 USB compatible




For Opel Saab Vauxhall 1992+
OP-COM Diagnostic Interface USB

Model: OPCOM

Firmware version:
1.59, not upgradable.

MCU:
compatible

Software version:
2010.08 Eng (compatible to Win XP, 7, 10)
2010.08 DE
2010.08 HU
2010.08 NL
2010.08 PL
2010.08 RO

2012.03 Eng (compatible to Win XP, 7. but not Win10)

2013.12 Eng (compatibility not confirmed yet)

USB driver:
Support 32/64bit
Windows 64bit, needs to disable driver signature enforcement.

Shipping Weight: 0.145kg

Add to Cart:

  • Model: OPCOM_1.59_compatible
  • Shipping Weight: 0.145KGs
  • 99 Units in Stock


This product was added to our catalog on Friday 09 June, 2017.

Your IP Address is: 54.80.60.91
Copyright © 2017 BuyOBD Taipei. Powered by Zen Cart